Stuttered sound during H?

Questions about configurations, etc

Moderator: Moderator

Fusees
Posts: 2
Joined: Thu Nov 03, 2022 8:39 pm

Stuttered sound during H?

Post by Fusees »

Hi guys!

The past week, I've tried to make a certain char compatible with some rapers (Brian and Kuro_Press) and so far, I've been satisfied with the result. Almost everything works good, but I've had one small problem.

When the H-animation is played out in mugen, the sound of the victim char kind of stutters and breaks half-way.
But when paused at the right time, the sound actually goes on like it should.

Nothing is really wrong with the sound, as it's just a copy/paste of one of the sounds that the char makes when it gets hit... yet when in H-phase, it just either breaks half-way or just doesn't play.

This is the only char that has this problem.
The ones I've done before don't really have this issue.

No idea how to correct this problem.
Any ideas?
LarkinSpark
Posts: 3
Joined: Thu Nov 03, 2022 8:58 pm

Re: Stuttered sound during H?

Post by LarkinSpark »

If there is anything that stops the sound on the character then that could be why. Also make sure that the playsnd does not share any channels with other playsnd sctrls(unless you want them to.). Channel -1 will make mugen choose any free channel, but will also play the sound over itself if there are free channels.

If you want the sound to always play all the way through without interrupting then set lowpriority to 1 while using it's own channel.

Code: Select all

[State 0, PlaySnd]
type = PlaySnd
trigger1 = 
value = 
volumescale = 100
channel = 5
lowpriority = 1
Fusees
Posts: 2
Joined: Thu Nov 03, 2022 8:39 pm

Re: Stuttered sound during H?

Post by Fusees »

LarkinSpark wrote: Thu Nov 03, 2022 10:58 pm If there is anything that stops the sound on the character then that could be why. Also make sure that the playsnd does not share any channels with other playsnd sctrls(unless you want them to.). Channel -1 will make mugen choose any free channel, but will also play the sound over itself if there are free channels.

If you want the sound to always play all the way through without interrupting then set lowpriority to 1 while using it's own channel.

Code: Select all

[State 0, PlaySnd]
type = PlaySnd
trigger1 = 
value = 
volumescale = 100
channel = 5
lowpriority = 1
Just tried the code, and tweaked the channel a bit.
It worked like a charm, thanks for the help! :)
Post Reply